Board index JavaServer Faces Extensions pe:layout with 3.4

pe:layout with 3.4

Community Driven Extensions Project

Post 16 Jul 2012, 15:53

Posts: 15115
Location: Cybertron

I get reports that pe:layout component is not working with 3.4 builds, can you please do a quick test when you have the time. Thanks.
PrimeFaces Lead

Post 17 Jul 2012, 10:08
Oleg User avatar
Expert Member

Posts: 3721
Location: Russia, Siberia => Germany, Black Forest
Hi Cagatay,

What is the problem exactly with pe:layout and PF 3.4-SNAPSHOT? We have 3.4-SNAPSHOT in the pom.xml and all layout use cases work smoothly - tested just now and could not see any errors. Also the entire showcase uses pe:layout. No problems.

By the way, pe:layout will be re-implemented this month. I had a long discussion with the creator of jQuery Layout plugin and decided to re-implement it from scratch. It will be more flexible and faster (I hope at least).
PrimeFaces 4.x, 5.x, Mojarra 2.2.x, JBoss WildFly, WebSphere, Windows 8.1, IntelliJ IDEA
PrimeFaces Cookbook: http://ova2.github.com/primefaces-cookbook/ PrimeFaces Extensions on GitHub: http://primefaces-extensions.github.com/

Post 17 Jul 2012, 10:32

Posts: 15115
Location: Cybertron

I don't know the exact problem with pe:layout on 3.4, I'll try it myself as well. Thanks for testing.

Will you write the layout yourself? What is the problem with jQuery layout plugin? Also why pe:layout and p:layout look different now :)
PrimeFaces Lead

Post 17 Jul 2012, 10:49

Posts: 15115
Location: Cybertron

Just tried with pe:layout and 3.4 trunk, worked fine. False alarm :)
PrimeFaces Lead

Post 17 Jul 2012, 10:58
Oleg User avatar
Expert Member

Posts: 3721
Location: Russia, Siberia => Germany, Black Forest
Will you write the layout yourself? What is the problem with jQuery layout plugin? Also why pe:layout and p:layout look different now

I think you have misunderstood me. I will use jQuery layout plugin. This is a good plugin. But I re-thought how to support all options, how to pass options, how to build nested layouts, etc. I don't want to pass options e.g. into JS script for the purpose of easy updates of nested layouts. It's difficult to explain because jQuery Layout has a lot of docu and samples which are not really good organised (big pot of mix infos).
PrimeFaces 4.x, 5.x, Mojarra 2.2.x, JBoss WildFly, WebSphere, Windows 8.1, IntelliJ IDEA
PrimeFaces Cookbook: http://ova2.github.com/primefaces-cookbook/ PrimeFaces Extensions on GitHub: http://primefaces-extensions.github.com/

Post 17 Jul 2012, 10:58
Oleg User avatar
Expert Member

Posts: 3721
Location: Russia, Siberia => Germany, Black Forest
Just tried with pe:layout and 3.4 trunk, worked fine. False alarm

Something went wrong on the side of reporters :-)
PrimeFaces 4.x, 5.x, Mojarra 2.2.x, JBoss WildFly, WebSphere, Windows 8.1, IntelliJ IDEA
PrimeFaces Cookbook: http://ova2.github.com/primefaces-cookbook/ PrimeFaces Extensions on GitHub: http://primefaces-extensions.github.com/

Post 15 Aug 2012, 20:22

Posts: 88
Location: Florida, United States
The false reports have proven prophetic. It seems that with upgrade of JQuery to 1.8.0, pe:layout no longer works. This is using PrimeFaces 3.4RC1.
The following error results:

Uncaught Error: Syntax error, unrecognized expression: :visible:

Thanks
PrimeFaces-4.0-SNAPSHOT / GlassFish 4 / JSF 2.2

Post 15 Aug 2012, 20:33

Posts: 15115
Location: Cybertron

Last colon character has to be removed, it is invalid. Jquery 1.8 has a new sizzle engine that is more strift to typos. That will fix the problem of pe:layout.

We have upgraded to jquery 1.8 recently so former reports are not related to this case.
PrimeFaces Lead

Post 15 Aug 2012, 21:05
Oleg User avatar
Expert Member

Posts: 3721
Location: Russia, Siberia => Germany, Black Forest
Guys, you're late :-). I have fixed this issue with :visible: today in the morning.

It seems we should release Extensions after PF 3.4 final as soon as possible. Unfortunately I'm on vacation from 20.08 until 03.09 and not at home. Is it ok for you if I will do a release after 03.09?

Thanks.
PrimeFaces 4.x, 5.x, Mojarra 2.2.x, JBoss WildFly, WebSphere, Windows 8.1, IntelliJ IDEA
PrimeFaces Cookbook: http://ova2.github.com/primefaces-cookbook/ PrimeFaces Extensions on GitHub: http://primefaces-extensions.github.com/

Post 04 Sep 2012, 22:59

Posts: 13
I'm curious when the release will be made?

Thanks for great work hope you had a great vaccation
Primefaces - 3.5
Primefaces Mobile 0.93
Myfaces 2.10
Weld 1.1.8
Tomcat 7

Next

Return to Extensions