Board index Premium Layouts and Themes Apollo Topbar profile menu not opening..

Topbar profile menu not opening..



Posts: 189
I am trying to use the Apollo theme but even if my topbar.xhtml file is equal to the one included in apollo-layout zip, the menu does not open when clicking on the profile picture, like it does on the demo site..
What am I missing?


Regards,

BTJ
PrimeFaces 6.0 | Jetty 9.3.14 | Mojarra 2.2.14
Arch Linux, Firefox and Chromium


Posts: 24
Greetings bjorntj,

I've experience this when I updated to version 1.0.1.

Try following the migration guide and replace all of your themes.

http://primefaces.org/apollo/docs.xhtml

Check on these also
layout.js
layout css files
animate.css

Last Resort: If all fails, create a new project with the one on 1.0.1 and re-add your code changes there.

Regards,
Philip


Posts: 189
Thx.. The "problem" is that this is a new project and I started right on 1.0.1, so should not be any migration problems..

BTJ
PrimeFaces 6.0 | Jetty 9.3.14 | Mojarra 2.2.14
Arch Linux, Firefox and Chromium


Posts: 24
Interesting...

Have you checked you server and browser console logs?

Did any error occurred?


Posts: 189
Yes, I have... I can not see any errors logged...

BTJ
PrimeFaces 6.0 | Jetty 9.3.14 | Mojarra 2.2.14
Arch Linux, Firefox and Chromium


Posts: 17240
Location: Cybertron

When you click the profile icon, do you see # appended to the url? Because that means event is not bound or url doesn't get # at the end at all?


Posts: 189
Sorry for the late reply (been a bit busy)

I just fired up the project and tried to see what happened to the url but now suddenly the menu opens (allthough I havent't touched the project since last time..) Not sure what happend but as long as it works.. :)


BTJ
PrimeFaces 6.0 | Jetty 9.3.14 | Mojarra 2.2.14
Arch Linux, Firefox and Chromium


Posts: 17240
Location: Cybertron

Glad to hear!


Return to Apollo