Diamond: Cant see svg background images / URL not working

UI Components for Vue
Post Reply
devte
Posts: 3
Joined: 21 Oct 2020, 22:14

06 Nov 2020, 14:29

Hi,
I just did a fresh install of the PrimeVuew Diamond template.
I noticed all of the pages in the "pages" section like landing, login, error are missing the svg background graphics.

I compared the online demo version with mine and noticed the URL in the CSS is different.

If I change the URL with the Browser Dev Tools from url("public/assets/layout/images/pages/landing/bg-contact.svg")
to url("/assets/layout/images/pages/landing/bg-contact.svg") the resource is found.

I am new to Vue. What can be the reason for this wrong URLs or that it cant be resolved?

Image

Image

Thank you.

tugce.kucukoglu
Posts: 4
Joined: 23 Oct 2020, 09:28

10 Nov 2020, 14:01

Hi,

Have you ever changed the sample project file structure?

If you want to change it, you should also change URLs manually in CSS files.

Best Regards,

devte
Posts: 3
Joined: 21 Oct 2020, 22:14

11 Nov 2020, 14:46

What I did was updating some dependencies including sass-loader which seems to be the reason why something went wrong. Still not sure why, for now I am working with the older versions.

mert.sincan
Posts: 4484
Joined: 29 Jun 2013, 12:38

12 Nov 2020, 01:04

Thanks a lot for the update! Maybe, this link can be related to your issue;
https://stackoverflow.com/questions/396 ... path-issue

Best Regards,

Post Reply

Return to “PrimeVue”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest