Resolved : Problem starting the project Roma Layout 6.0.0

Post Reply
User avatar
modo86
Posts: 5
Joined: 20 Mar 2014, 11:24
Location: Bulgaria
Contact:

29 Jul 2021, 11:44

Hello,
I've bought that layout yestarday, but I am facing problems with starting the downloaded project.

That is the log created after npm install command usage on default package roma-react-6.0.0 :

https://storage.happycompany.ltd/d/f/633705625697697250

I've tried to update the dependencies in package.json, remove package-lock.json and node_modules :

Code: Select all

"dependencies": {
        "@fullcalendar/core": "5.9.0",
        "@fullcalendar/daygrid": "5.9.0",
        "@fullcalendar/interaction": "5.9.0",
        "@fullcalendar/timegrid": "5.9.0",
        "axios": "^0.21.1",
        "chart.js": "3.5.0",
        "classnames": "^2.3.1",
        "node-sass": "^6.0.1",
        "primeflex": "3.0.1",
        "primeicons": "4.1.0",
        "primereact": "6.5.0",
        "prismjs": "^1.24.1",
        "quill": "^1.3.7",
        "react": "^17.0.2",
        "react-app-polyfill": "^2.0.0",
        "react-dom": "^17.0.2",
        "react-router-dom": "^5.2.0",
        "react-scripts": "4.0.3",
        "react-transition-group": "^4.4.2"
    },
Then the npm install command prints that :

Code: Select all

npm WARN deprecated @hapi/bourne@1.3.2: This version has been deprecated and is no longer supported or maintained
npm WARN deprecated @hapi/topo@3.1.6: This version has been deprecated and is no longer supported or maintained
npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
npm WARN deprecated sane@4.1.0: some dependency vulnerabilities fixed, support for node < 10 dropped, and newer ECMAScript syntax/features added
npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
npm WARN deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
npm WARN deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
npm WARN deprecated querystring@0.2.0: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.
npm WARN deprecated babel-eslint@10.1.0: babel-eslint is now @babel/eslint-parser. This package will no longer receive updates.
npm WARN deprecated @hapi/address@2.1.4: Moved to 'npm install @sideway/address'
npm WARN deprecated rollup-plugin-babel@4.4.0: This package has been deprecated and is no longer maintained. Please use @rollup/plugin-babel.
npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated @hapi/hoek@8.5.1: This version has been deprecated and is no longer supported or maintained
npm WARN deprecated @hapi/joi@15.1.1: Switch to 'npm install joi'
npm WARN deprecated core-js@2.6.12: core-js@<3.3 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Please, upgrade your dependencies to the actual version of core-js.

added 2042 packages, and audited 2043 packages in 59s

152 packages are looking for funding
  run `npm fund` for details

11 moderate severity vulnerabilities

To address issues that do not require attention, run:
  npm audit fix

To address all issues possible (including breaking changes), run:
  npm audit fix --force

Some issues need review, and may require choosing
a different dependency.

Run `npm audit` for details.
Then I am using npm start to test the layout .... the page is loading and in 2-5 seconds prints that error :

Code: Select all

Failed to compile
./src/App.scss (./node_modules/css-loader/dist/cjs.js??ref--5-oneOf-6-1!./node_modules/postcss-loader/src??postcss!./node_modules/resolve-url-loader??ref--5-oneOf-6-3!./node_modules/sass-loader/dist/cjs.js??ref--5-oneOf-6-4!./src/App.scss)
Error: Can't resolve '@fullcalendar/core/main.css' in '/Users/iliyahristov/IdeaProjects/roma-react-6.0.0/src'
I've tried a cople of thinks to fix it but without success.

npm --version
7.19.1
node --version
v16.5.0
yarn --version
1.22.10

Are you planing to upgrade the theme with the new dependencies ?
Any help is apricatable.
Thank you

Regards
Last edited by modo86 on 29 Jul 2021, 17:08, edited 1 time in total.
Using :
PrimeFaces 5.0 Final, GlassFish 4.0, MySql Server, Java 7, JSF 2.2

http://dssale.com

User avatar
modo86
Posts: 5
Joined: 20 Mar 2014, 11:24
Location: Bulgaria
Contact:

29 Jul 2021, 14:25

After some hours playing the demo has started ....
The right dependencies were :

Code: Select all

"dependencies": {
        "@fullcalendar/core": "^4.4.2",
        "@fullcalendar/daygrid": "^4.4.2",
        "@fullcalendar/interaction": "^4.4.2",
        "@fullcalendar/timegrid": "^4.4.2",
        "axios": "^0.21.1",
        "chart.js": "^3.4.1",
        "classnames": "^2.3.1",
        "node-sass": "^6.0.1",
        "primeflex": "2.0.0",
        "primeicons": "4.1.0",
        "primereact": "6.5.0",
        "prismjs": "^1.16.0",
        "quill": "^1.3.7",
        "react": "^17.0.2",
        "react-app-polyfill": "^2.0.0",
        "react-dom": "^17.0.2",
        "react-router-dom": "^5.2.0",
        "react-scripts": "4.0.3",
        "react-transition-group": "^4.4.2"
    }
Using :
PrimeFaces 5.0 Final, GlassFish 4.0, MySql Server, Java 7, JSF 2.2

http://dssale.com

Post Reply

Return to “Roma - PrimeReact”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest