Icon not displayed correctly

Post Reply
bogdan.nica
Posts: 7
Joined: 22 Dec 2020, 17:28

16 Feb 2021, 13:10

Hello,
I can't display the icons so in the rain theme presented on the primefaces.org

This is what it looks like at https://www.primefaces.org/rain/icons.xhtml
https://drive.google.com/file/d/19uiWXo ... sp=sharing


The same icon looks like this in my application
https://drive.google.com/file/d/1Zb4hhr ... sp=sharing


My code code is:

Code: Select all

 <i class="pi pi-user"></i>
How can i solve?
Thanks a lot

siris
Posts: 144
Joined: 29 Jul 2019, 13:57

22 Feb 2021, 09:24

Hi,

I can't access your drive images. And when I try in my local rain I can't see any problem. Can you give more detailed information about where and how it doesn't work?

Best Regards,

bogdan.nica
Posts: 7
Joined: 22 Dec 2020, 17:28

27 Apr 2021, 12:19

Sorry, the new link:

in my application:
https://drive.google.com/file/d/1Zb4hhr ... sp=sharing


in Rain theme preview (on primefaces.org):
https://drive.google.com/file/d/19uiWXo ... sp=sharing

mert.sincan
Posts: 4670
Joined: 29 Jun 2013, 12:38

04 May 2021, 14:59

Hi,

Sorry for the delayed response! Which PF and Rain version are you using? Also, could you please check the font-family value of .pi class in the inspector of the browser?

Code: Select all

.pi {
    font-family: 'primeicons';   /* Please check this line in browser */
    speak: none;
    font-style: normal;
    font-weight: normal;
    font-variant: normal;
    text-transform: none;
    line-height: 1;
    display: inline-block;
    -webkit-font-smoothing: antialiased;
    -moz-osx-font-smoothing: grayscale;
}
Best Regards,

Post Reply

Return to “Rain - PrimeFaces”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest