pe:layout with 3.4

Community Driven Extensions Project
cagatay.civici
Prime
Posts: 18165
Joined: 05 Jan 2009, 00:21
Location: Cybertron
Contact:

04 Sep 2012, 23:11

Oleg, Thomas, fyi PF 3.4 used jQuery 1.8.1 and UI 1.8.23

User avatar
Oleg
Expert Member
Posts: 3803
Joined: 02 Oct 2009, 09:41
Location: Germany, Black Forest

05 Sep 2012, 17:40

Hi Cagatay. Thanks. What does it mean for us?

P.S. 0.6.0-SNAPSHOT runs fine with PF 3.4.
PrimeFaces Cookbook (2. edition): http://ova2.github.io/primefaces-cookbook/ Learning Angular UI Development with PrimeNG: https://github.com/ova2/angular-develop ... th-primeng Blog: https://medium.com/@OlegVaraksin

texess
Posts: 95
Joined: 03 Jun 2012, 14:04

07 Sep 2012, 17:26

I also had issues with PE and PF 3.4, so went back to 3.3.

Will wait for 0.6 final ;)

Regards,

Tex
PF 3.4.1
PE 0.6.0

michael.v
Posts: 8
Joined: 29 Aug 2012, 14:15

13 Sep 2012, 09:32

Hi,

yesterday's afternoon I spent on investigating why pe:layout
  • - was rendered correctly when I started my site on 127.0.0.1:8080/
    - was broken when started on localhost:8080
    - was broken when any of my co-workers started the site either on their or on my local tomcat.
Then I cleared my local browser cache and found pe:layout broken also when started on 127.0.0.1:8080. The error reported by Firefox error console always was like:
Zeitstempel: 13.09.2012 08:37:56
Fehler: Error: Syntax error, unrecognized expression: :visible:
Quelldatei: http://localhost:8080/kvsh/javax.faces. ... primefaces
Zeile: 21
Meanwhile I'm beginning to understand why. So what can I do to overcome this fault?

Regards,

Michael

Primefaces 3.4, Primefaces Extensions 0.5.1, MyFaces 2.1.8, Tomcat 7.0

nileshmali
Posts: 110
Joined: 10 Nov 2010, 13:43
Location: Pune, India
Contact:

13 Sep 2012, 09:57

Primefaces Extesions 0.5.1 is not compatible with Primefaces 3.4

Please try creating local snapshot build from primefaces extensions source.
Nilesh N. Mali
---
Angular 2.x | Prime NG
FF: latest | Chrome: latest | vscode
Blog: http://nileshmali.blogspot.in | PrimeFaces Extensions: https://github.com/primefaces-extensions

michael.v
Posts: 8
Joined: 29 Aug 2012, 14:15

13 Sep 2012, 11:11

Thanks, Nilesh, I'll try what you suggest.

What I learned from this is that the local browser cache may be a tremendous pitfall. In this case something stored in my browser cache was able to obscure the incompatibility of PF 3.4 to PE 0.5.1 - until I cleared it. That makes me fear that vice versa this local browser cache may also fake incompatibilities if they are expired but not updated.

OK, first of all, I'll set

Code: Select all

<context-param>
    <param-name>org.primefaces.extensions.WRAP_PRIME_FACES_RESOURCES</param-name>
    <param-value>false</param-value>
</context-param>
Will that be efficient and sufficient? Should I find a way to globally disable browser caching for our site?

Appreciating any ideas,

Michael

nileshmali
Posts: 110
Joined: 10 Nov 2010, 13:43
Location: Pune, India
Contact:

13 Sep 2012, 11:17

Hi,

you can use:

Code: Select all

<meta http-equiv="cache-control" content="no-cache"/>

to disable cache.

But it may have performance impact. As each time you request a page all resources will be fetched again from server.

And IMO use:

Code: Select all

<context-param>
    <param-name>org.primefaces.extensions.WRAP_PRIME_FACES_RESOURCES</param-name>
    <param-value>true</param-value>
</context-param>
Nilesh N. Mali
---
Angular 2.x | Prime NG
FF: latest | Chrome: latest | vscode
Blog: http://nileshmali.blogspot.in | PrimeFaces Extensions: https://github.com/primefaces-extensions

apsarabanu
Posts: 3
Joined: 20 Aug 2012, 14:16

21 Sep 2012, 09:49

Hi everyone,
You need to check out Panels everywhere. There might be some adjustments needed for Omega theme and PE were little on raw side ..

Post Reply

Return to “Extensions”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest