CKEditor: Synchronous XMLHttpRequest Warning

Community Driven Extensions Project
Post Reply
lastresort
Posts: 11
Joined: 07 Nov 2016, 11:14

12 Sep 2017, 10:19

I'm getting the snychronous XMLHttpRequest warning when using the pe:ckeditor on my page:

[Deprecation] Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/. jquery.js.jsf?ln=primefaces&v=6.1:formatted:5880

I've tested it with chrome and firefox. As soon as I remove the ckeditor the warning is gone.

You can also see the warning on the showcase: https://www.primefaces.org/showcase-ext ... cUsage.jsf.

On the official CKEditor sample pages the warning doesn't appear so the cause should be in the PE sources, so I've searched the pe:ckeditor sources on git for a synchronous request and can't find any.

Does anyone have an idea what could be the cause of the warning?
Primefaces 6.1.8 | Wildfly 10.1 | Primefaces Extensions 6.1.5

tandraschko
PrimeFaces Core Developer
Posts: 3271
Joined: 03 Dec 2010, 14:11
Location: Bavaria, DE
Contact:

12 Sep 2017, 11:22

Always Bet On Prime (+ Extensions)!

Thomas Andraschko
PrimeFaces Developer | PrimeFaces Extensions Founder
Apache OpenWebBeans PMC | Apache DeltaSpike PMC | Apache MyFaces PMC

Personal Blog: http://tandraschko.blogspot.de/

lastresort
Posts: 11
Joined: 07 Nov 2016, 11:14

12 Sep 2017, 11:33

Ah that's why i didn't find anything. It's in the primefaces core. Thanks for the info :)
Primefaces 6.1.8 | Wildfly 10.1 | Primefaces Extensions 6.1.5

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 2 guests