How to install Rio?

mert.sincan
Posts: 4121
Joined: 29 Jun 2013, 12:38

12 Feb 2016, 09:25

You don't have dashboard.xhtml page in your project. Please remove outcome="dashboard.xhtml" attribute in menuitem(in layoutmenu.xhtml).

BlueDragon
Posts: 4
Joined: 07 Jul 2016, 20:25

07 Jul 2016, 20:36

HI, I want to install, I download the rio-layout-3.1.2 ( I buy it!) I write in my pom like this!

<dependency>
<groupId>org.primefaces</groupId>
<artifactId>primefaces</artifactId>
<version>6.0</version>
</dependency>
<dependency>
<groupId>org.primefaces.themes</groupId>
<artifactId>rio-theme-3.1.2</artifactId>
<version>3.1.2</version>
</dependency>

but I have this message:

The POM for org.primefaces.themes:rio-theme-3.1.2:jar:3.1.2 is missing, no dependency information available


PLEEEEESE HELLP! :(

BlueDragon
Posts: 4
Joined: 07 Jul 2016, 20:25

08 Jul 2016, 18:05

hiii, me again :D, so, I find a new clue,I must install the theme in my project right?,
when I install the .jar of rio with maven command

mvn install:install-file -X Dfile=C:\Prime\Rio-3.1.2 -DgroupId=org.primefaces.themes -DartifactId=rio -Dversion=3.1.2 -Dpackaging=jar

note. I execute the command in the path of my project...

I have a new error of maven... :(


[DEBUG] Skipped remote request for org.apache.maven.plugins/maven-metadata.xml, locally cached metadata up-to-date.
[DEBUG] Could not find metadata org.codehaus.mojo/maven-metadata.xml in local (C:\Users\Sistemas3\.m2\repository)
[DEBUG] Skipped remote request for org.codehaus.mojo/maven-metadata.xml, locally cached metadata up-to-date.
[DEBUG] Could not find metadata org.apache.maven.plugins/maven-metadata.xml in local (C:\Users\Sistemas3\.m2\repository)
[DEBUG] Could not find metadata org.codehaus.mojo/maven-metadata.xml in local (C:\Users\Sistemas3\.m2\repository)
[DEBUG] Using transporter WagonTransporter with priority -1.0 for https://repo.maven.apache.org/maven2
[DEBUG] Using transporter WagonTransporter with priority -1.0 for https://repo.maven.apache.org/maven2
[DEBUG] Using connector BasicRepositoryConnector with priority 0.0 for https://repo.maven.apache.org/maven2
[DEBUG] Using connector BasicRepositoryConnector with priority 0.0 for https://repo.maven.apache.org/maven2
Downloading: https://repo.maven.apache.org/maven2/or ... tadata.xml
Downloading: https://repo.maven.apache.org/maven2/or ... tadata.xml
Downloaded: https://repo.maven.apache.org/maven2/or ... tadata.xml (13 KB at 10.0 KB/sec)
[DEBUG] Writing tracking file C:\Users\Sistemas3\.m2\repository\org\apache\maven\plugins\resolver-status.properties
Downloaded: https://repo.maven.apache.org/maven2/or ... tadata.xml (20 KB at 14.8 KB/sec)
[DEBUG] Writing tracking file C:\Users\Sistemas3\.m2\repository\org\codehaus\mojo\resolver-status.properties
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2.711 s
[INFO] Finished at: 2016-07-08T10:51:14-05:00
[INFO] Final Memory: 10M/158M
[INFO] ------------------------------------------------------------------------
[ERROR] No plugin found for prefix 'Dfile=C' in the current project and in the plugin groups [org.apache.maven.plugins, org.codehaus.mojo] available from the repositories [local (C:\Users\Sistemas3\.m2\repository), central (https://repo.maven.apache.org/maven2)] -> [Help 1]
org.apache.maven.plugin.prefix.NoPluginFoundForPrefixException: No plugin found for prefix 'Dfile=C' in the current project and in the plugin groups [org.apache.maven.plugins, org.codehaus.mojo] available from the repositories [local (C:\Users\Sistemas3\.m2\repository), central (https://repo.maven.apache.org/maven2)]
at org.apache.maven.plugin.prefix.internal.DefaultPluginPrefixResolver.resolve(DefaultPluginPrefixResolver.java:93)
at org.apache.maven.lifecycle.internal.MojoDescriptorCreator.findPluginForPrefix(MojoDescriptorCreator.java:265)
at org.apache.maven.lifecycle.internal.MojoDescriptorCreator.getMojoDescriptor(MojoDescriptorCreator.java:219)
at org.apache.maven.lifecycle.internal.DefaultLifecycleTaskSegmentCalculator.calculateTaskSegments(DefaultLifecycleTaskSegmentCalculator.java:103)
at org.apache.maven.lifecycle.internal.DefaultLifecycleTaskSegmentCalculator.calculateTaskSegments(DefaultLifecycleTaskSegmentCalculator.java:83)
at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:89)
at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)
at org.apache.maven.cli.MavenCli.main(MavenCli.java:199)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
[ERROR]
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/disp ... xException



Please help.... :( :(

mert.sincan
Posts: 4121
Joined: 29 Jun 2013, 12:38

11 Jul 2016, 13:51

Hi,

Please use "-Dfile" instead of "Dfile". Please see; https://maven.apache.org/guides/mini/gu ... local.html

Code: Select all

mvn install:install-file -Dfile=<path-to-file> -DgroupId=org.primefaces.themes -DartifactId=rio -Dversion=3.1.2 -Dpackaging=jar

BlueDragon
Posts: 4
Joined: 07 Jul 2016, 20:25

13 Jul 2016, 07:58

Hiii, thank's a lot! I install with the command and follow the steps with pom etc, but now when I deploy my project the next error is:

javax.servlet.ServletException: Error loading theme, cannot find "theme.css" resource of "primefaces-rio" library


if I see my dependencies here /Dependencies/ Rio :S... so.... I am creazy jejeje... :lol:


sorry my answer late!.... but I am playing with maven :D please help!! ...I'm very close

BlueDragon
Posts: 4
Joined: 07 Jul 2016, 20:25

13 Jul 2016, 08:40

yeah!!!! I.....do it!!!! thank's...... jajajaja only copy the resources of zip rio in my directory of web-inf and work's .....


thanks a lot!!!!! :lol: :lol: :lol: :lol: :lol:

mert.sincan
Posts: 4121
Joined: 29 Jun 2013, 12:38

15 Jul 2016, 15:58

Glad to hear, thanks for the update :)

Locked

Return to “Rio”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest