FileUpload browse button does not work in a TabView

UI Components for JSF
Post Reply
krahe
Posts: 52
Joined: 09 Nov 2011, 19:13
Location: Rockford, Michigan, USA
Contact:

13 Oct 2021, 21:31

I am using PrimeFaces 8.0.6. I have two pages that contain a FileUpload component. One is a rather simple form backed by a session-scoped bean that works fine whether the user uploads a file by either choosing it with the browse button or dragging and dropping a file on the component. The other is a more complex form where FileUpload is contained in a Tab on a TabView component, backed by a conversation-scoped bean. That one also works fine when the user drags and drops a file to be uploaded onto the FileUpload component. However, if they try to use the browse button to choose a file to upload, the File Upload dialog opens so they can choose a file to upload, but nothing happens when they press Open other than the dialog closes. There is no error message in the browser or in the server log. Nothing. It's as if they hit the Cancel button on the File Upload dialog rather than Open.

I looked through the change logs for later 8.x versions, but didn't see any bug fixes related to FileUpload. Does anyone know if this has been fixed in any version of PrimeFaces 8 later than 8.0.6? Or in 10? (FileUpload worked fine in 7.0.12.) Here is my FileUpload code:

Code: Select all

<p:fileUpload id="attachupload" mode="advanced" auto="true" immediate="true"
              listener="#{quoteEditBean.uploadAttachment}" label="#{msgs.AttachmentChooseFileButtonLabel}"
              disabled="#{empty quoteEditBean.profileIdxToUploadAttachment or empty quoteEditBean.attachmentToUploadType}"
              sizeLimit="10485760" update="qtv:addatttree qtv:prftv" />
Thank you.

jepsar
Posts: 38
Joined: 03 Sep 2014, 11:41
Location: NL / BE
Contact:

14 Oct 2021, 16:11

Did you try with 10.0.0 or 11.0.0-RC1?
PrimeFaces (Extensions) Contributor
GitHub Profile: https://github.com/jepsar

krahe
Posts: 52
Joined: 09 Nov 2011, 19:13
Location: Rockford, Michigan, USA
Contact:

14 Oct 2021, 17:09

I finally figured out how to download 10.0.0 (not as simple as it used to be). Unfortunately, the situation is even worse there than it is in 8.0.6. Not only is the browse button missing completely, but drag & drop doesn't even work. That probably doesn't matter, though, as 10.0 does not appear to be a viable upgrade path for my application for a host of other reasons. I do have some earlier 8.0 versions I can try. Maybe one of them predates the regression. If not, I will have to back down to 7.0 to get my application usable again (and hope that when I upgraded to 8.0 many months ago it wasn't because of a problem I was having with 7.0).

krahe
Posts: 52
Joined: 09 Nov 2011, 19:13
Location: Rockford, Michigan, USA
Contact:

14 Oct 2021, 17:37

The issue does not exist in 8.0.5, so that is the one I will go with at this point.

Post Reply

Return to “PrimeFaces”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 20 guests