Vulnerable jQuery version

UI Components for JSF
PrimeFaces Core Developer
Posts: 3371
Joined: 03 Dec 2010, 14:11
Location: Bavaria, DE

06 Apr 2017, 20:38

Great, so please come back if you have some news to share! :)
Always Bet On Prime (+ Extensions)!

Thomas Andraschko
PrimeFaces Developer | PrimeFaces Extensions Founder
Apache OpenWebBeans PMC | Apache DeltaSpike PMC | Apache MyFaces PMC

Personal Blog:

Posts: 1
Joined: 03 May 2017, 14:54

08 May 2017, 13:56

We have a similar problem with jQuery 1.11.3.
We have to migrate an application from Richfaces to Primefaces, but jquery 1.11.3 would give us problems with the security team. So we would like to upgrade to jQuery 1.12.4.
I already tested primefaces with jQuery 1.12.4 and did not find problems in my test application. But then I read, that the oncomplete function could be broken ( Do you have any experiences, which problems arise with jQuiery 1.12.4 or is there a concrete bug list?
Thanks in advance,

User avatar
Posts: 522
Joined: 22 Apr 2013, 15:48

17 May 2017, 13:42

It was updated to 2.2.4 yesterday.
PrimeFaces Extensions Developer
GitHub Profile:
PrimeFaces Elite 6.2 / PF Extensions 6.2

Expert Member
Posts: 8828
Joined: 17 Jun 2010, 13:34
Location: Netherlands

18 May 2017, 08:07

Wow... such a major update in a 'minor' release where no-one of the community can get hold of... I think this would justify an additional community release (just like I always found it 'good' to after some weeks a small bugfix release would be justified)
Ronald van Kuijk
PrimeFaces 6.1, PrimeFaces plus 0.0.2 | JbossWildfly 10.1| Mojarra 2.2.13
Fedora 61, Firefox 'most recent'
Read the forum posting rules

Post Reply
  • Information
  • Who is online

    Users browsing this forum: Bing [Bot] and 8 guests