input text and unicode character

UI Components for JSF
Post Reply
JFISUC
Posts: 1
Joined: 08 Apr 2021, 08:30

10 Apr 2021, 10:25

Hello.
I have a PrimeFaces input text box in which user can start the value with '!' (Unicode character) for a separate logic to be applied.
But for some reason when the value is submitted (via ajax) to back end bean property the ! is missing. Other characters like @ is working.
Last edited by JFISUC on 12 May 2021, 12:40, edited 4 times in total.
watch live cam sex show / chat with nude cam girls / find the hottest web cam girls

Melloware
Posts: 2817
Joined: 22 Apr 2013, 15:48

11 Apr 2021, 14:18

Go here to the "KeyUp" example: https://www.primefaces.org/showcase/ui/ajax/basic.xhtml

I can press "!" and it submits it just fine?
PrimeFaces Developer | PrimeFaces Extensions Developer
GitHub Profile: https://github.com/melloware
PrimeFaces Elite 10.0.4 / PF Extensions 10.0.3

tandraschko
PrimeFaces Core Developer
Posts: 3855
Joined: 03 Dec 2010, 14:11
Location: Bavaria, DE
Contact:

12 Apr 2021, 09:12

try using a utf8 encoding filter
Thomas Andraschko

PrimeFaces | PrimeFaces Extensions

Apache Member | OpenWebBeans, DeltaSpike, MyFaces, BVal, TomEE

Sponsor me: https://github.com/sponsors/tandraschko
Blog: http://tandraschko.blogspot.de/
Twitter: https://twitter.com/TAndraschko

Melloware
Posts: 2817
Joined: 22 Apr 2013, 15:48

12 Apr 2021, 13:49

Omnifaces has a built in one you can use: https://showcase.omnifaces.org/filters/ ... dingFilter
PrimeFaces Developer | PrimeFaces Extensions Developer
GitHub Profile: https://github.com/melloware
PrimeFaces Elite 10.0.4 / PF Extensions 10.0.3

Post Reply

Return to “PrimeFaces”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 20 guests