sass-maven-plugin:2.2 requires Maven version 3.2.5

Beny1700
Posts: 4
Joined: 08 Jul 2016, 17:19

14 Jul 2016, 15:38

Hi,

I try to run the tag project of the icarus ressources via Netbeans 8.1

I get this error: "The plugin nl.geodienstencentrum.maven:sass-maven-plugin:2.20 requires Maven version 3.2.5"

The actual version of Maven is 4.00

Any idea how to get it work?

cagatay.civici
Prime
Posts: 18141
Joined: 05 Jan 2009, 00:21
Location: Cybertron
Contact:

14 Jul 2016, 16:40

Maybe your netbeans still uses the built in one? I had this error and pointed netbeans to my local maven distro which fixed it.

Beny1700
Posts: 4
Joined: 08 Jul 2016, 17:19

14 Jul 2016, 18:22

Well I found a way a bit tricky:

I wen to C:\Users\quent_000\.m2\repository\nl\geodienstencentrum\maven\sass-maven-plugin\2.20

modify the .pom to remove the maven version prerequisite...

Now the project run but I have another issue (see pictures):
Image

Image

Image

Image

It is like if some CSS was not applied, I saw also a ressource not found error in the chrome console..
I just imported the project, is there some guidlines to follow?

Beny1700
Posts: 4
Joined: 08 Jul 2016, 17:19

14 Jul 2016, 18:32

When i check the HTML page from http://localhost:8080/tag/dashboard.xhtml

I see the RES_NOT_FOUND, see Html code below

<html xmlns="http://www.w3.org/1999/xhtml"><head id="j_idt2">
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<link type="text/css" rel="stylesheet" href="/tag/javax.faces.resource/theme.css.xhtml?ln=primefaces-icarus-orange" />
<link type="text/css" rel="stylesheet" href="/tag/javax.faces.resource/fa/font-awesome.css.xhtml?ln=primefaces&v=6.0" />
<link type="text/css" rel="stylesheet" href="/tag/javax.faces.resource/components.css.xhtml?ln=primefaces&v=6.0" />
<script type="text/javascript" src="/tag/javax.faces.resource/jquery/jquery.js.xhtml?ln=primefaces&v=6.0"></script>
<script type="text/javascript" src="/tag/javax.faces.resource/core.js.xhtml?ln=primefaces&v=6.0"></script>
<script type="text/javascript" src="/tag/javax.faces.resource/components.js.xhtml?ln=primefaces&v=6.0"></script>
<script type="text/javascript" src="/tag/javax.faces.resource/jquery/jquery-plugins.js.xhtml?ln=primefaces&v=6.0"></script>
<link type="text/css" rel="stylesheet" href="/tag/javax.faces.resource/charts/charts.css.xhtml?ln=primefaces&v=6.0" />
<script type="text/javascript" src="/tag/javax.faces.resource/charts/charts.js.xhtml?ln=primefaces&v=6.0"></script>
<link type="text/css" rel="stylesheet" href="/tag/javax.faces.resource/css/nanoscroller.css.xhtml?ln=icarus-layout" />
<link type="text/css" rel="stylesheet" href="RES_NOT_FOUND" />
<script type="text/javascript">if(window.PrimeFaces){PrimeFaces.settings.locale='fr_CH';}</script>

<title>PrimeFaces Icarus</title>
<script type="text/javascript" src="/tag/javax.faces.resource/js/nanoscroller.js.xhtml?ln=icarus-layout"></script>
<script type="text/javascript" src="/tag/javax.faces.resource/js/layout.js.xhtml?ln=icarus-layout"></script>
<script type="text/javascript">

Beny1700
Posts: 4
Joined: 08 Jul 2016, 17:19

14 Jul 2016, 23:08

OK found the problem.

Some css were missing in tag\src\main\webapp\resources\icarus-layout\css

those css:
layout-blue.css
layout-red.css
layout-green.css
layout-orange.css


It is a bit frustrating to pay for a template and found some error like that in it :s

aragorn
Posts: 3765
Joined: 29 Jun 2013, 12:38

15 Jul 2016, 10:27

Thanks for the update. Is issue resolved?

ora1521
Posts: 32
Joined: 12 Apr 2011, 13:44
Location: Warsaw, Poland

21 Jul 2016, 14:01

Hi,

With Omega I have the same problem. Lack of css files...

Best,

Lukasz

aragorn
Posts: 3765
Joined: 29 Jun 2013, 12:38

21 Jul 2016, 14:10

Which PF version are you using? Can you please attach errors for us? Also, after you download new version(Omega Layout 1.0.1), can you please try it?

ora1521
Posts: 32
Joined: 12 Apr 2011, 13:44
Location: Warsaw, Poland

21 Jul 2016, 14:17

I have PF6.0 & Omega 1.0.1. I have added omega project to NB 8.0.2 and I have build it & deployed on Glassfissh 4:

(...)
INFO: Initializing Mojarra 2.2.0 ( 20130502-2118 https://svn.java.net/svn/mojarra~svn/tags/2.2.0@11930) for context '/tag'
INFO: Running on PrimeFaces 6.0
INFO: Loading application [omega] at [/tag]
INFO: omega was successfully deployed in 11 688 milliseconds.

As so no specific errors within Glassfish logs. On first page I can see the same problem as it was previously declared:

<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml"><head id="j_idt2">
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0" />
<meta name="apple-mobile-web-app-capable" content="yes" /><link type="text/css" rel="stylesheet" href="/tag/javax.faces.resource/theme.css.xhtml?ln=primefaces-omega" /><link type="text/css" rel="stylesheet" href="/tag/javax.faces.resource/fa/font-awesome.css.xhtml?ln=primefaces&v=6.0" /><link type="text/css" rel="stylesheet" href="/tag/javax.faces.resource/components.css.xhtml?ln=primefaces&v=6.0" /><script type="text/javascript" src="/tag/javax.faces.resource/jquery/jquery.js.xhtml?ln=primefaces&v=6.0"></script><script type="text/javascript" src="/tag/javax.faces.resource/jquery/jquery-plugins.js.xhtml?ln=primefaces&v=6.0"></script><script type="text/javascript" src="/tag/javax.faces.resource/core.js.xhtml?ln=primefaces&v=6.0"></script><script type="text/javascript" src="/tag/javax.faces.resource/components.js.xhtml?ln=primefaces&v=6.0"></script><link type="text/css" rel="stylesheet" href="/tag/javax.faces.resource/charts/charts.css.xhtml?ln=primefaces&v=6.0" /><script type="text/javascript" src="/tag/javax.faces.resource/charts/charts.js.xhtml?ln=primefaces&v=6.0"></script><link type="text/css" rel="stylesheet" href="/tag/javax.faces.resource/css/nanoscroller.css.xhtml?ln=omega-layout" /><link type="text/css" rel="stylesheet" href="RES_NOT_FOUND" /><script type="text/javascript">if(window.PrimeFaces){PrimeFaces.settings.locale='pl_PL';}</script>
<title>PrimeFaces Omega</title><script type="text/javascript" src="/tag/javax.faces.resource/js/nanoscroller.js.xhtml?ln=omega-layout"></script><script type="text/javascript" src="/tag/javax.faces.resource/js/layout.js.xhtml?ln=omega-layout"></script>
<script type="text/javascript">

And this is true. I do not see any ccs files. Directory ... resources\omega-layout\css consists only grid.css & nanoscroller.css


Post Reply

Return to “Icarus”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 2 guests