Page 1 of 1

Question (before purchase)

Posted: 26 May 2018, 00:41
by jarsa.steven
Hi,

Just want to know if it's necessary to have Maven or Gradel to use Omega PrimeFaces Theme ?

I build a Java EE application with PrimeFaces without Maven/Gradel and I want to change the Theme.

It's a pretty urgent request.

Thanks in advance.

Steven

Re: Question (before purchase)

Posted: 29 May 2018, 07:05
by aragorn
Hi Steven,

Thanks a lot for your interest.
Just want to know if it's necessary to have Maven or Gradel to use Omega PrimeFaces Theme ?
- You can use it without Maven/Gradel. it is enough for you to add theme.jar and sass file for Omega layout.

Best Regards,

Re: Question (before purchase)

Posted: 29 May 2018, 07:49
by jarsa.steven
Hi aragorn,

Thanks a lot for your reply.

Great, so let's buy this theme ! :)
Will give you a feed back, as soon as implement it.

Best regards,

Steven

Re: Question (before purchase)

Posted: 29 May 2018, 08:23
by aragorn
I think this link can help to you;
https://www.dropbox.com/s/s9cle2xqbwbu8 ... t.mp4?dl=0 (Note; please download video to watch on quality resolution)

Best Regards,

Re: Question (before purchase)

Posted: 30 May 2018, 15:51
by jarsa.steven
Hi,

Thanks for the video !

I'm getting this error when trying to access to any pages .xhtml :

" Error loading theme, cannot find "theme.css" resource of "primefaces-omega" library "

I don't have any theme.css under "src/main/webapp/WEB-INF/resources/omega-layout/css"

Thanks for your help :)

Steven

Re: Question (before purchase)

Posted: 31 May 2018, 02:40
by aragorn
Which PrimeFaces version are you using? Could you please attach template.xhtml and web.xml?

Re: Question (before purchase)

Posted: 31 May 2018, 18:28
by jarsa.steven
I think the problem was coming from PrimeFaces 5.0 !

Now I use 6.2 version and ALL is ok :)

I move all my project under a Maven project and all is working well for the moment ! I've got the theme loaded, css working well, it's going on !

Delivery date is Friday the 8th of June, finger crossed ! :D

Thanks for all.

Steven

Re: Question (before purchase)

Posted: 04 Jun 2018, 08:13
by aragorn
Glad to hear, thanks a lot for the update!

Note: I suggest that you use PF6.2 version because of including some security fixes.

Best Regards,