Topbar profile menu not opening..

User avatar
bjorntj
Posts: 213
Joined: 30 Jul 2010, 10:46

18 Aug 2016, 21:10

I am trying to use the Apollo theme but even if my topbar.xhtml file is equal to the one included in apollo-layout zip, the menu does not open when clicking on the profile picture, like it does on the demo site..
What am I missing?


Regards,

BTJ
PrimeFaces 6.1 | Jetty 9.4.6 | Mojarra 2.2.14
Arch Linux, Firefox and Chromium

cloud4288
Posts: 24
Joined: 16 Jun 2011, 11:10

19 Aug 2016, 05:49

Greetings bjorntj,

I've experience this when I updated to version 1.0.1.

Try following the migration guide and replace all of your themes.

http://primefaces.org/apollo/docs.xhtml

Check on these also
layout.js
layout css files
animate.css

Last Resort: If all fails, create a new project with the one on 1.0.1 and re-add your code changes there.

Regards,
Philip

User avatar
bjorntj
Posts: 213
Joined: 30 Jul 2010, 10:46

19 Aug 2016, 09:33

Thx.. The "problem" is that this is a new project and I started right on 1.0.1, so should not be any migration problems..

BTJ
PrimeFaces 6.1 | Jetty 9.4.6 | Mojarra 2.2.14
Arch Linux, Firefox and Chromium

cloud4288
Posts: 24
Joined: 16 Jun 2011, 11:10

22 Aug 2016, 05:28

Interesting...

Have you checked you server and browser console logs?

Did any error occurred?

User avatar
bjorntj
Posts: 213
Joined: 30 Jul 2010, 10:46

22 Aug 2016, 08:33

Yes, I have... I can not see any errors logged...

BTJ
PrimeFaces 6.1 | Jetty 9.4.6 | Mojarra 2.2.14
Arch Linux, Firefox and Chromium

User avatar
optimus.prime
Prime
Posts: 17586
Joined: 05 Jan 2009, 00:21
Location: Cybertron
Contact:

22 Aug 2016, 10:58

When you click the profile icon, do you see # appended to the url? Because that means event is not bound or url doesn't get # at the end at all?

User avatar
bjorntj
Posts: 213
Joined: 30 Jul 2010, 10:46

01 Sep 2016, 15:13

Sorry for the late reply (been a bit busy)

I just fired up the project and tried to see what happened to the url but now suddenly the menu opens (allthough I havent't touched the project since last time..) Not sure what happend but as long as it works.. :)


BTJ
PrimeFaces 6.1 | Jetty 9.4.6 | Mojarra 2.2.14
Arch Linux, Firefox and Chromium

User avatar
optimus.prime
Prime
Posts: 17586
Joined: 05 Jan 2009, 00:21
Location: Cybertron
Contact:

01 Sep 2016, 20:01

Glad to hear!

ntapan
Posts: 9
Joined: 02 Sep 2015, 16:35

22 Jun 2017, 17:13

Hi,

I have the same problem,
when I click the profile photo, menu doesn't occur.

"#" appears at the end of the url.
What could be the solution?

Thanks,

User avatar
aragorn
Posts: 2643
Joined: 29 Jun 2013, 12:38

23 Jun 2017, 08:47

Did you try it with the latest Apollo theme version?

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest