Page 1 of 2

Using Apollo theme

Posted: 27 Aug 2016, 20:37
by ViperV
Hi Sorry for this stupid question , but i bought the premium theme and its not very clear on how to use it in my project.

I saw another post like this and the video on it didn't explain much .

any help please?

Re: Using Apollo theme

Posted: 29 Aug 2016, 02:51
by cloud4288
  • 1. Extract the downloaded zip file.
    2. Go to the apollo directory and you will see a tag directory go there and copy it's content.
    apollo-1.0.1
    |
    |-- tag <--- copy the contents of this directory

    3. Create a new project using maven.
    4. Paste it in your project.
    somewhere in your file system
    |
    | -- your project <-- paste it here
    5. Open it in your favorite IDE. (ex. Netbeans)
    6. Download Sass and point your IDE there. (If not done yet.)
    7. Follow this http://primefaces.org/apollo/docs.xhtml if needed.
    8. Maven should not be able to see apollo-theme-1.0.1.jar, fix it and use Nexus or Artifactory. (Google is your friend)

Re: Using Apollo theme

Posted: 29 Aug 2016, 08:18
by aragorn
+1, thanks @cloud4288 :)

Re: Using Apollo theme

Posted: 29 Aug 2016, 23:01
by herdoizad
Hello, I already followed the steps but I get not use Apollo theme.

Where I can get documentation or a tutotial video for using Apollo theme?

Thank you.

Re: Using Apollo theme

Posted: 31 Aug 2016, 02:49
by cloud4288
@herdoizad, May I see the structure of your project?

Make sure to compile SaSS.

Code: Select all

sass --update src/main/webapp/resources/ --sourcemap=none
Where I can get documentation or a tutotial video for using Apollo theme?
Here a link to the documentation. http://primefaces.org/apollo/docs.xhtml

Re: Using Apollo theme

Posted: 31 Aug 2016, 16:11
by cagatay.civici
Make sure to compile SaSS.
This is only required if you want to make changes.

The sample maven project placed inside the tag folder of the distribution is a good start. If you have a working application already, then you need to follow the steps at docs. Let us know if you have any issues.

Re: Using Apollo theme

Posted: 03 Oct 2016, 05:48
by jblaplace
topbar.xhtml is broken in v1.0.1 (haven't checked 1.0).

One need to replace class in

<p:graphicImage class="logo" library="apollo-layout" name="images/apollo_logo.png" />

by styleClass

<p:graphicImage styleClass="logo" library="apollo-layout" name="images/apollo_logo.png" />

Re: Using Apollo theme

Posted: 04 Oct 2016, 14:02
by cagatay.civici
@aragorn, can you fix this at our codebase and we'll make it available in next release?

Re: Using Apollo theme

Posted: 11 Jan 2018, 02:22
by co2n
@cloud4288
I've followed, then I run it on http://localhost:8080/apollo/
using Remote GlassFish Server 5.
but I received a message

exception

javax.servlet.ServletException: Error loading css, can not find "theme.css" resource of "primefaces-apollo-blue-light" library

why happened like this?

Re: Using Apollo theme

Posted: 12 Jan 2018, 18:17
by co2n
the issue is resolved :D