DataTable to TurboTable issues

Post Reply
tengel92
Posts: 28
Joined: 15 Sep 2016, 20:04

28 Mar 2018, 21:13

I think I have a fairly complicated DataTable that I'm trying to migrate to utilize TurboTable. I've supplied a Plunker below with the code I'm trying to use. On the Plunker I'd like to search the first field with the value 230148 for both tables.

TurboTable
-If you select the first row both rows are highlighted where I feel like it should just be the first one.
-If you click the rowexpander it opens both where it should be just the one that was clicked.
-Reset functionality mostly works but it does not clear the value, in our case 230148 from the input (this however does work some of the other filters like calendar.
-Responsive look is not great on Ultima with the new TurboTable. I believe I have the correct CSS settings.
-The only way I could get the sort and filter was stack the two of them but this make it appear more boxy where I'd prefer the datatable look which is more integrated with the sort and filter being in the same box.

I know this is likely at fault for some of these issues but without it can't get rowexpander to work at all.

Code: Select all

dataKey="DataChangePrimaryID"
Desired functionality is that of the DataTable
-If you select the first row only the first row is highlighted
-If you click the rowexpander it opens only the one that was clicked.
-Reset functionality works as expected.
-Responsive works well.
-Filter and sort are together in one box.

https://embed.plnkr.co/7Y3Mox/

merve7
Posts: 251
Joined: 12 Sep 2017, 10:44

02 May 2018, 08:54

Please see examples in http://primefaces.org/primeng/#/table and try with PrimeNG 5.2.5. If the problem still exists, please send p-table part of your code.

Post Reply

Return to “Ultima - PrimeNG”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 2 guests