Error "Wrong number of arguments" when updating to ultima theme 9

Post Reply
comanlaviniaelena
Posts: 10
Joined: 18 Aug 2020, 10:20

18 Aug 2020, 10:50

Hello,

I have migrated my application from Angular 8 to angular 9.1.12 and PrimeNg to version 9.1.3.
I also want to update ultima theme to 9, but I have a problem when trying to generate the css files.

I get the following error:

Code: Select all

Error: wrong number of arguments(4 for 3) for 'rgb'
on line 75 of src/assets/sass/theme/_common.scss
It seems to be a typo. Maybe rgba was intended here?

Could you please help?

#Angular9.1.12 #PrimeNg9.1.3

DavidSilverlight
Posts: 9
Joined: 29 Jan 2020, 12:14

05 Sep 2020, 20:25

I ran into the same issue using a different theme recently. It appears to be a bug that was released with the them from what I can tell. I changed it to rgba and it worked, allowing the css to be generated.

comanlaviniaelena
Posts: 10
Joined: 18 Aug 2020, 10:20

07 Sep 2020, 07:11

Hi,

Thank you for feedback!
I did in the same way but, I think this needs to be solved also officially in the ultima theme.
I don't think is ok to change the ultima code theme, I expect to have it complete and just use it as it is. :)

DavidSilverlight
Posts: 9
Joined: 29 Jan 2020, 12:14

11 Sep 2020, 13:32

I agree. Hopefully they will see the post and correct it.

mert.sincan
Posts: 4638
Joined: 29 Jun 2013, 12:38

09 Oct 2020, 22:23

Hi,

Could you please try it with the latest Ultima version?

Best Regards,

comanlaviniaelena
Posts: 10
Joined: 18 Aug 2020, 10:20

30 Oct 2020, 12:57

Hi,

Just wanted to let you know that this problem is solved in Ultima 10, but the same error is given on other classes.
I've opened a separate ticket for this: viewtopic.php?f=45&t=63851

Thank you!

mert.sincan
Posts: 4638
Joined: 29 Jun 2013, 12:38

09 Nov 2020, 10:59

Thanks a lot for the update, @comanlaviniaelena!

Best Regards,

Post Reply

Return to “Ultima - PrimeNG”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 2 guests