Errors when update to PrimeNG Ultima 10 theme

Post Reply
comanlaviniaelena
Posts: 10
Joined: 18 Aug 2020, 10:20

20 Oct 2020, 12:55

Hello,

I have an angular application migrated to Angular 10, primeNG 10.0.3, primeicons 4.0.0.
I want to update to Ultima 10 theme but I get several errors:
- wrong number of arguments (3 of 4) for rgba in _variables.scss, line 2
- undefined variable:"$primaryTextColor" in _config.scss, line 105

After fixing manually all these issues, layout css is generated based on scss files. But when compiling in VS, I receive:
(Emitted value instead of an instance of Error) CssSyntaxError: D:\sass\layout\_fonts.scss:15:9: Can't resolve '../../layout/fonts/roboto-v20-latin-ext_latin-500.woff' in 'D:\GIT\WorkOrderFulfilment\src\assets\layout\css'

When checking sass\layout\_fonts.scss I see it is referencing files, f.e.:
@font-face {
font-family: 'Roboto';
font-style: normal;
font-weight: 500;
src: local('Roboto Medium'), local('Roboto-Medium'),
url('../../layout/fonts/roboto-v20-latin-ext_latin-500.woff2') format('woff2'), /* Chrome 26+, Opera 23+, Firefox 39+ */
url('../../layout/fonts/roboto-v20-latin-ext_latin-500.woff') format('woff'); /* Chrome 6+, Firefox 3.6+, IE 9+, Safari 5.1+ */
}
layout/fonts/roboto-v20-latin-ext_latin-500.woff2 and layout/fonts/roboto-v20-latin-ext_latin-500.woff that do NOT exist in assets/layout/fonts.
So unfortunately, I cannot continue in any way with the update to Ultima 10.

Please help!

mert.sincan
Posts: 4638
Joined: 29 Jun 2013, 12:38

21 Oct 2020, 07:48

Hi,

@merve and @yigit Could you please check this issue?

We'll get back to you asap.
Best Regards,

merve7
Posts: 690
Joined: 12 Sep 2017, 10:44

21 Oct 2020, 11:18

Hi,
Firstly, so sorry for your issues.
1) we fixed rgba confusion for the next release.
2) Are you sure changed your layout files (src/assets/layout/css/*.scss) with the new version? We added "$primaryTextColor" variable in layout/*.scss files for v10 and _config.scss file uses this variables.
3)Lastly, you need to update assets/layout/fonts folder.

comanlaviniaelena
Posts: 10
Joined: 18 Aug 2020, 10:20

27 Oct 2020, 13:47

Hi,

Thank you for your reply.

1.) Ok.

2.) Yes, in this case, I've changed all files correctly.
I've changed the layout files, the error I get related to primaryTextColor is:
Error: Undefined variable: "$primaryTextColor".
on line 105 of D:/GIT/WorkOrderFulfilment/src/assets/sass/layout/_config.scss
from line 16 of D:/GIT/WorkOrderFulfilment/src/assets/sass/layout/_layout.scss
from line 14 of D:\GIT\WorkOrderFulfilment\src\assets\layout\css\layout-abs.scss

And when checking in _config.scss, line 105, I have:
i {
font-size: 1rem;
font-weight: 600;
position: absolute;
color: $primaryTextColor;;
top: 50%;
left: 50%;
margin-left: -.5rem;
margin-top: -.5rem;
}
It works only after changing it manually to: color: "$primaryTextColor";

Also, I get same error when generating theme.css:
Error: Undefined variable: "$primaryTextColor".
on line 102 of D:/GIT/WorkOrderFulfilment/src/assets/sass/theme/_variables.scss
from line 1 of D:/GIT/WorkOrderFulfilment/src/assets/sass/theme/_theme.scss
from line 9 of D:\GIT\WorkOrderFulfilment\src\assets\theme\theme-abs.scss
In src/assets/sass/theme/_variables.scss, line 102:
$buttonTextColor:$primaryTextColor;

Change it manually to $buttonTextColor:"$primaryTextColor"; and it works.

Also here:
Error: Undefined variable: "$primaryTextColor".
on line 98 of D:/GIT/WorkOrderFulfilment/src/assets/sass/theme/designer/components/button/_button.scss
from line 27 of D:/GIT/WorkOrderFulfilment/src/assets/sass/theme/designer/_components.scss
from line 3 of D:/GIT/WorkOrderFulfilment/src/assets/sass/theme/_theme.scss
from line 9 of D:\GIT\WorkOrderFulfilment\src\assets\theme\theme-abs.scss

.p-badge {
margin-left: $inlineSpacing;
min-width: $fontSize;
height: $fontSize;
line-height: $fontSize;
color: $primaryColor;
background-color: "$primaryTextColor";
}
Change it manually to: background-color: "$primaryTextColor";

And a lot more places where this error message is given and I had to solve it manually...

3.) Thank you, I did not updated assets/layout/fonts folder correctly.

Also, could you please let me know when a next release will be available for Ultima theme with points 1 and 2 solved?

Thank you in advance for answer!

comanlaviniaelena
Posts: 10
Joined: 18 Aug 2020, 10:20

28 Oct 2020, 11:21

Hi, again,

After solving all issues manually, I've succeeded to update to Ultima 10 but, the look and feel is completely different than Angular 9 PrimeNG Ultima 9, so in my application everything is changed.
I want to update to Ultima 10 but not to have everything changed and reimplement what is already done in the application.
Is there a backward compatibility between 9 and 10?
Could you please help with an answer?
We really need to know in order to decide how to continue.

Kind regards,
Lavinia

mert.sincan
Posts: 4638
Joined: 29 Jun 2013, 12:38

30 Oct 2020, 09:47

Hi,
Is there a backward compatibility between 9 and 10?
- Unfortunately, no. Everything was re-implemented in accordance with the PrimeOne concept. Also, please see this guide;
https://github.com/primefaces/primeng/w ... -Migration

Best Regards,

mert.sincan
Posts: 4638
Joined: 29 Jun 2013, 12:38

30 Oct 2020, 09:49

@merve7 Could you please check @comanlaviniaelena's changes in above comment?

Best Regards,

merve7
Posts: 690
Joined: 12 Sep 2017, 10:44

10 Nov 2020, 15:50

Hi,
We released the new version(10.0.1), you can reach it from the store.

Post Reply

Return to “Ultima - PrimeNG”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest