Page 1 of 1

Error when loading Barcelona-ng 1.0.2 in IE11

Posted: 28 Apr 2017, 15:42
by uffehh
Hi,

When loading the Barcelona-lg layout in IE11 the load screen keeps going forever and the console displays this error (translated from Danish):
SCRIPT5007: The property 'Apply' can not be retrieved for the reference, which is undefined or null

I am using the version 1.0.2 of the barcelone-ng layout. In Chrome everything works perfect.

Re: Error when loading Barcelona-ng 1.0.2 in IE11

Posted: 01 May 2017, 10:56
by aragorn
Please change polyfill.js.

new polyfill.js;

Code: Select all

// This file includes polyfills needed by Angular and is loaded before the app.
// You can add your own extra polyfills to this file.
import 'core-js/es6/symbol';
import 'core-js/es6/object';
import 'core-js/es6/function';
import 'core-js/es6/parse-int';
import 'core-js/es6/parse-float';
import 'core-js/es6/number';
import 'core-js/es6/math';
import 'core-js/es6/string';
import 'core-js/es6/date';
import 'core-js/es6/array';
import 'core-js/es6/regexp';
import 'core-js/es6/map';
import 'core-js/es6/set';
import 'core-js/es6/reflect';

import 'core-js/es7/reflect';
import 'zone.js/dist/zone';

// If you need to support the browsers/features below, uncomment the import
// and run `npm install import-name-here';
// Learn more in https://angular.io/docs/ts/latest/guide/browser-support.html

// Needed for: IE9
import 'classlist';

// Animations
// Needed for: All but Chrome and Firefox, Not supported in IE9
// import 'web-animations-js';

// Date, currency, decimal and percent pipes
// Needed for: All but Chrome, Firefox, Edge, IE11 and Safari 10
// import 'intl';

// NgClass on SVG elements
// Needed for: IE10, IE11
// import 'classlist.js';

Also, please add 'classlist' into your package.json;

Code: Select all

...
"dependencies": {
   ...
    "classlist": "^1.0.1"
  },
...

Re: Error when loading Barcelona-ng 1.0.2 in IE11

Posted: 01 May 2017, 10:59
by aragorn

Re: Error when loading Barcelona-ng 1.0.2 in IE11

Posted: 03 May 2017, 08:57
by uffehh
After applying the proposed fix, the page loads fine in IE11.
Thanks for the quick response.

Re: Error when loading Barcelona-ng 1.0.2 in IE11

Posted: 04 May 2017, 10:52
by aragorn
Glad to hear, thanks for the update!