Confusing dependencies

UI Components for React
Post Reply
Vsevolod Golovanov
Posts: 8
Joined: 12 May 2014, 16:09

21 Mar 2020, 19:28

https://www.primefaces.org/primereact/showcase/#/setup specifies the following dependencies:

Code: Select all

dependencies: {
    "react": "^16.6.3",
    "react-dom": "^16.6.3",
    "react-transition-group": "^2.5.1"
    "classnames": "^2.2.6",
    "primeicons": "^1.0.0"
}
But https://www.npmjs.com/package/primereact says:

Code: Select all

dependencies: {
    "react": "^16.0.0",
    "react-dom": "^16.0.0",
    "react-transition-group": "^2.2.1",
    "classnames": "^2.2.5",
    "primeicons": "^2.0.0"
}
This is a bit confusing, the versions are all different. You may say, only major versions matter. OK, but there are different major versions for primeicons?

But the most confusing thing to me is why are these dependencies not specified in primereact's package.json itself? Then they'd be properly versioned depending on primereact's own version, and it'll be a single source of truth. Is this some kind of React quirk that I don't know about?

cagatay.civici
Prime
Posts: 18223
Joined: 05 Jan 2009, 00:21
Location: Cybertron
Contact:

23 Mar 2020, 16:58

We'll sync to make them consistent thank you.

Post Reply

Return to “PrimeReact”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest