Integrate primereact app in my app

UI Components for React
Post Reply
rodolfohill
Posts: 2
Joined: 13 Aug 2018, 00:13

13 Aug 2018, 19:26

I need to make a React application, Redux compatible
Are the components that you have, are Redux compatible? I suppose so, however I take the opportunity to ask you this question.

First I made an application in Spring Boot, which will provide security through JWT, apart from delivering all the WS.
Then, I did a UI application with 3 pages, the Login, Home Page and Logoff application. This application uses Redux.

I wanted to integrate sigma for home page, but I found it impossible.

Then take the project code https://www.primefaces.org/primereact (https://github.com/primefaces/primereact)

I'm very close to achieving it however I have some warnings and errors.

Warnings

PS C:\Informa\react-redux-registration-login> npm install
npm WARN extract-text-webpack-plugin@3.0.0 requires a peer of webpack@^3.1.0 but none is installed. You must install peer dependencies yourself.
npm WARN sw-precache-webpack-plugin@0.11.4 requires a peer of webpack@^1 || ^2 || ^2.1.0-beta || ^2.2.0-beta || ^3 but none is installed. You must install peer dependencies yourself.
npm WARN uglifyjs-webpack-plugin@0.4.6 requires a peer of webpack@^1.9 || ^2 || ^2.1.0-beta ||
^2.2.0-rc || ^3.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN webpack-dev-middleware@1.12.2 requires a peer of webpack@^1.0.0 || ^2.0.0 || ^3.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN webpack-manifest-plugin@1.2.1 requires a peer of webpack@1 || 2 || 3 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.2 (node_modules\react-scripts\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

up to date in 70.589s
[!] 31 vulnerabilities found [21413 packages audited]
Severity: 6 Low | 11 Moderate | 14 High
Run `npm audit` for more detail

User avatar
sudheer
PrimeFaces Core Developer
Posts: 4344
Joined: 16 Oct 2011, 19:19
Location: Singapore

03 Sep 2018, 12:33

PrimeReact should work independently with respect to Redux usage. The stacktrace shows that it is not related to PrimeReact. Do I miss anything?
Author,Speaker
https://twitter.com/sudheerjonna
Github: https://github.com/sudheerj
Website http://sudheerjonna.com/

___________________
Sudheer Jonna

cagatay.civici
Prime
Posts: 18049
Joined: 05 Jan 2009, 00:21
Location: Cybertron
Contact:

03 Sep 2018, 13:21

Yes, PrimeReact is a UI library and can work with or without Redux enabled applications, the logs do not reveal anything related to PrimeReact.

Post Reply

Return to “PrimeReact”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest