Atlantis theme

Post Reply
China Steel
Posts: 2
Joined: 19 Aug 2017, 09:06

27 Sep 2017, 05:44

1) Which node and angular-Cli version is suitable for Atlantis theme?
2) When i compile atlantis theme on Node 8.5 version with angular-cli 1.4.2, it shows an error in menudemo.ts file for megaMenuItems variable on line 138, which shows that "items" field inside the megaMenuItems has "items []" but it is using [[]] (array of array) which is right. But with the different version of node and cli, it is not showing. However i have resolve that error but the confusion is why different node version works differently.

3) I am working on 5 different PC with Atlantis theme, and they are not working as expected.
Following are the different error comes up when i change the node version.
- "Error: You have to be inside angular-cli directory."
- "Error: Cannot read property "config" of null"
And project works when i install Node > 7 and < 8 without changing anything in the project structure or coding.

tandraschko
PrimeFaces Core Developer
Posts: 3234
Joined: 03 Dec 2010, 14:11
Location: Bavaria, DE
Contact:

27 Sep 2017, 10:33

use the PrimeNG subforum - You are in the PrimeFaces subforum here
Always Bet On Prime (+ Extensions)!

Thomas Andraschko
PrimeFaces Developer | PrimeFaces Extensions Founder
Apache OpenWebBeans PMC | Apache DeltaSpike PMC | Apache MyFaces PMC

Personal Blog: http://tandraschko.blogspot.de/

User avatar
w00f
Posts: 54
Joined: 27 Apr 2016, 13:27
Location: Ankara, Turkey
Contact:

10 Oct 2017, 09:08

tandraschko wrote:
27 Sep 2017, 10:33
use the PrimeNG subforum - You are in the PrimeFaces subforum here
Topic is moved to Atlantis - PrimeNG subforum.

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest