Compatibility Issue with Node/Anglar-cli versions

Post Reply
China Steel
Posts: 5
Joined: 19 Aug 2017, 09:06

27 Sep 2017, 13:59

1) Which node and angular-Cli version is suitable for Atlantis theme?
2) When i compile atlantis theme on Node 8.5 version with angular-cli 1.4.2, it shows an error in menudemo.ts file for megaMenuItems variable on line 138, which shows that "items" field inside the megaMenuItems has "items []" but it is using [[]] (array of array) which is right. But with the different version of node and cli, it is not showing. However i have resolve that error but the confusion is why different node version works differently.

3) I am working on 5 different PC with Atlantis theme, and they are not working as expected.
Following are the different error comes up when i change the node version.
- "Error: You have to be inside angular-cli directory."
- "Error: Cannot read property "config" of null"
And project works when i install Node > 7 and < 8 without changing anything in the project structure or coding.

Also, in some PC it works for Node8.1.2 version and in Some PC its not with the same node version.
:?: :?: :?:

merve7
Posts: 316
Joined: 12 Sep 2017, 10:44

04 Oct 2017, 10:16

Themes are not related to node. Themes are related angular/cli and angular/cli is related to node. If the angular/cli is compatible with the node versions, themes are compatible with those versions.

Prerequisites

Both the CLI and generated project have dependencies that require Node 6.9.0 or higher, together with NPM 3 or higher.
( https://github.com/angular/angular-cli#prerequisites )

Post Reply

Return to “Atlantis - PrimeNG”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest