Page 1 of 2

Icon content in all themes

Posted: 23 Jun 2018, 06:51
by biohazard52
Hello I bought the manhattan theme and in all of the provided color scheme theme.css files the content properties are a square box (image provided); for all the icons. What do I do about this?
Image

Re: Icon content in all themes

Posted: 26 Jun 2018, 10:54
by aragorn
I think this may be related to your editor. Does these icons display in browser? Exp; <p:commandButton icon="ui-icon-triangle-1-e" ...

Re: Icon content in all themes

Posted: 27 Jun 2018, 16:01
by biohazard52
aragorn wrote:
26 Jun 2018, 10:54
I think this may be related to your editor. Does these icons display in browser? Exp; <p:commandButton icon="ui-icon-triangle-1-e" ...
No the icons are not displayed, any component that has an icon also displays the box shown in the image. I tried to download the theme again but the result was the same.

Re: Icon content in all themes

Posted: 28 Jun 2018, 08:57
by aragorn
Thanks a lot for the update. Did you try our sample maven project?

Also, you need to use sass -w src/main/webapp/resources/ --sourcemap=none command to provide CSS files from SASS files.

Re: Icon content in all themes

Posted: 28 Jun 2018, 19:57
by biohazard52
aragorn wrote:
28 Jun 2018, 08:57
Thanks a lot for the update. Did you try our sample maven project?

Also, you need to use sass -w src/main/webapp/resources/ --sourcemap=none command to provide CSS files from SASS files.
I have not tried the sample project. Could you provide a link? I couldn't find any documentation about using a premium theme so I added the files to my project and came to my current result.

Re: Icon content in all themes

Posted: 28 Jun 2018, 20:21
by biohazard52
biohazard52 wrote:
28 Jun 2018, 19:57
aragorn wrote:
28 Jun 2018, 08:57
Thanks a lot for the update. Did you try our sample maven project?

Also, you need to use sass -w src/main/webapp/resources/ --sourcemap=none command to provide CSS files from SASS files.
I have not tried the sample project. Could you provide a link? I couldn't find any documentation about using a premium theme so I added the files to my project and came to my current result.
I was able to find documentation after doing some more searching. I will go over it and see if the problem persists. It would be helpful if the documentation was included in the zip file for the theme or a read me file pointing to the documentation. Thanks you for your time!

Re: Icon content in all themes

Posted: 29 Jun 2018, 01:58
by biohazard52
I found out that it's an issue with sass and how they write unicode characters in the current version. What version of sass is suggested?

Re: Icon content in all themes

Posted: 02 Jul 2018, 08:20
by aragorn
Thanks a lot for the update! I'm using SASS 3.5.1.

Regards,

Re: Icon content in all themes

Posted: 18 Jul 2018, 22:58
by biohazard52
Sorry for the delay but I attempted to use the same version of ruby sass as you said you're using and the result was the same. Is there any other option to resolve this? Currently I paid for a premium theme and it's unusable.

Re: Icon content in all themes

Posted: 19 Jul 2018, 10:25
by huseyinT
Could you send a sample XHTML file for testing?