avalon 1.0.7 not compatible pf7.0

Post Reply
valucky
Posts: 2
Joined: 25 Jul 2015, 13:00

19 Mar 2019, 14:20

Hello

I'm tried upgrade to primefaces 7.0 , but the avalon 1.0.7 said that
java.lang.NoSuchMethodError: org.primefaces.avalon.component.menu.AvalonMenuRenderer.buildAjaxRequest(Ljavax/faces/context/FacesContext;Lorg/primefaces/component/api/AjaxSource;Ljavax/faces/component/UIComponent;)Ljava/lang/String;
at org.primefaces.avalon.component.menu.AvalonMenuRenderer.encodeMenuItem(AvalonMenuRenderer.java:243) ~[avalon-theme-1.0.7.jar:?]

the BaseMenuRenderer in 7.0 not contians these method:
protected String buildAjaxRequest(FacesContext context, AbstractMenu menu, AjaxSource source, UIComponent form, Map<String, List<String>> params)

pls help me

Thanks
Andras

marcelocaser
Posts: 91
Joined: 13 Dec 2011, 15:07

20 Mar 2019, 12:13

Hi,
Premium templates do not yet support PrimeFaces 7.0, our team will update all the templates to bring in 7.0 support as soon as possible.

valucky
Posts: 2
Joined: 25 Jul 2015, 13:00

24 Mar 2019, 12:47

Thanks
marcelocaser wrote:
20 Mar 2019, 12:13
Hi,
Premium templates do not yet support PrimeFaces 7.0, our team will update all the templates to bring in 7.0 support as soon as possible.

Valen
Posts: 1
Joined: 31 Aug 2017, 00:29

11 Apr 2019, 21:17

Buenas tardes, para cuando tiene previsto solucionar este problema de compatibilidad?. Premium debería de ser prioridad.
Saludos.

aragorn
Posts: 3718
Joined: 29 Jun 2013, 12:38

17 Apr 2019, 08:35

Hi,

The new version released. Please try it. Migration Guide; https://www.primefaces.org/avalon/docs.xhtml

Best Regards,

Post Reply

Return to “Avalon - PrimeFaces”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest