Designer api will not run

Post Reply
Posts: 2
Joined: 04 May 2019, 08:57

06 May 2019, 02:06

Hi Prime
I have just paid for and tried to load the designer api. I have downloaded both version 3.1.0 and 3.0.0.

After downloading, i yarn install the project, this works fine.

Then attempt to yarn start. This is the error that occurs:

Code: Select all

$ react-scripts start

There might be a problem with the project dependency tree.
It is likely not a bug in Create React App, but something you need to fix locally.

The react-scripts package provided by Create React App requires a dependency:

  "babel-loader": "8.0.4"

Don't try to install it manually: your package manager does it automatically.
However, a different version of babel-loader was detected higher up in the tree:

  c:\code\primereact-designer-3.0.0\node_modules\babel-loader (version: 8.0.5)

Manually installing incompatible versions is known to cause hard-to-debug issues.

If you would prefer to ignore this check, add SKIP_PREFLIGHT_CHECK=true to an .env file in your project.
That will permanently disable this message but you might encounter other issues.

To fix the dependency tree, try following the steps below in the exact order:

  1. Delete package-lock.json (not package.json!) and/or yarn.lock in your project folder.
  2. Delete node_modules in your project folder.
  3. Remove "babel-loader" from dependencies and/or devDependencies in the package.json file in your project folder.
  4. Run npm install or yarn, depending on the package manager you use.

In most cases, this should be enough to fix the problem.
If this has not helped, there are a few other things you can try:

  5. If you used npm, install yarn ( and repeat the above steps with it instead.
     This may help because npm has known issues with package hoisting which may get resolved in future versions.

  6. Check if c:\code\primereact-designer-3.0.0\node_modules\babel-loader is outside your project directory.
     For example, you might have accidentally installed something in your home folder.

  7. Try running npm ls babel-loader in your project folder.
     This will tell you which other package (apart from the expected react-scripts) installed babel-loader.

If nothing else helps, add SKIP_PREFLIGHT_CHECK=true to an .env file in your project.
That would permanently disable this preflight check in case you want to proceed anyway.

Posts: 2
Joined: 04 May 2019, 08:57

06 May 2019, 09:34

I have found the problem.

Actually there are two.

First, the Designer API is not supported on node 10.5.13, it is on 8.10.0

Second, the chartjs npm version is too old.

Need to update package.json from

Code: Select all

"dependencies": {
        "axios": "^0.15.3",
        "babel-polyfill": "^6.26.0",
        "chart.js": "^2.4.0",

Code: Select all

"dependencies": {
        "axios": "^0.15.3",
        "babel-polyfill": "^6.26.0",
        "chart.js": "^2.7.1",
I'd submit a PR but not OS

Posts: 690
Joined: 12 Sep 2017, 10:44

08 May 2019, 13:48

So sorry for the delay. We released the new version (PrimeReact Designer 3.1.1). Could you try with the new version?

Post Reply

Return to “PrimeReact Theme Designer API”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 0 guests