Resource loading in portlet environment

Components, Ajax Framework, Utilities and More.
Post Reply
Robelind
Posts: 15
Joined: 01 Dec 2009, 09:11

10 Mar 2011, 15:21

HI.

I'm deploying the "Prime portlet" (http://primefaces.googlecode.com/svn/ex ... me-portlet) in Liferay 6.0.5 and having problems with PrimeFaces resource loading.
No resources, e.g. javascript or css files are loaded correctly. In the generated html there are links like e.g.:

Code: Select all

<script type="text/javascript" src="http://localhost:8180/web/guest/test?_1_WAR_primeportlet100SNAPSHOT_INSTANCE_11oL__1_WAR_primeportlet100SNAPSHOT_INSTANCE_11oL_javax.faces.resource=jquery%252Fui%252Fjquery-ui.js&_1_WAR_primeportlet100SNAPSHOT_INSTANCE_11oL__1_WAR_primeportlet100SNAPSHOT_INSTANCE_11oL_ln=primefaces&_1_WAR_primeportlet100SNAPSHOT_INSTANCE_11oL_javax.faces.resource=javax.faces.resource%3Djquery%252Fui%252Fjquery-ui.js%26_1_WAR_primeportlet100SNAPSHOT_INSTANCE_11oL_ln%3Dprimefaces%26p_p_cacheability%3DcacheLevelPage%26p_p_col_count%3D2%26p_p_col_id%3Dcolumn-1%26p_p_col_pos%3D1%26p_p_id%3D1_WAR_primeportlet100SNAPSHOT_INSTANCE_11oL%26p_p_lifecycle%3D2%26p_p_mode%3Dview%26p_p_state%3Dnormal&p_p_cacheability=cacheLevelPage&p_p_cacheability=cacheLevelPage&p_p_col_count=2&p_p_col_count=2&p_p_col_id=column-1&p_p_col_id=column-1&p_p_col_pos=1&p_p_col_pos=1&p_p_id=1_WAR_primeportlet100SNAPSHOT_INSTANCE_11oL&p_p_id=1_WAR_primeportlet100SNAPSHOT_INSTANCE_11oL&p_p_lifecycle=2&p_p_lifecycle=2&p_p_mode=view&p_p_mode=view&p_p_state=normal&p_p_state=normal&v=2.2.1&v=2.2.1"></script>
I have not modified the project in any way, just built it, deployed it and placed the portlet on a page called "Test".
What could be the cause of this?

Robelind
Posts: 15
Joined: 01 Dec 2009, 09:11

14 Mar 2011, 10:52

Any ideas on this?

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 14 guests