jetty-maven-plugin does not work with any version

Locked
chsmcol
Posts: 4
Joined: 19 Jan 2016, 03:19
Location: Charlotte
Contact:

19 Jan 2016, 18:23

Hi All,
how is it going?

I just bought Rio and I can't get it to run the maven example. it give me the following error: The POM for org.mortbay.jetty:jetty-maven-plugin:jar:8.1.16.v20140903 is missing, no dependency information available. I have also tried new versions but still does not work. the following is the .pom plugin that came with the purchased theme:

<plugin>
<groupId>org.mortbay.jetty</groupId>
<artifactId>jetty-maven-plugin</artifactId>
<version>8.1.16.v20140903</version>
<configuration>
<webAppConfig>
<contextPath>/rio</contextPath>
</webAppConfig>
<scanIntervalSeconds>5</scanIntervalSeconds>
<connectors>
<connector implementation="org.eclipse.jetty.server.nio.SelectChannelConnector">
<port>8084</port>
</connector>
</connectors>
</configuration>
</plugin>

can anyone help me?

Christian.
-----------------

Torsten
Posts: 27
Joined: 29 Oct 2015, 11:49

22 Jan 2016, 16:56

the pom.xml has to be in the project folder, not any deeper.

Maven doesn't find it.

Why do you use the Jetty Maven plugin?
Put up a Glassfish or Tomcat depending on how your stuff will be deployed later.
You will have much less problems later.
I never finish anyth..

mert.sincan
Posts: 4352
Joined: 29 Jun 2013, 12:38

25 Jan 2016, 11:03

Do you have mvn in your PC? if no, please see; https://www.youtube.com/watch?v=Jtj-0yhox5s
Then build the project and run it.

Locked

Return to “Rio”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest