Icons on Chrome 61 Not working [solved]

UI Components for JSF
Post Reply
giovannicandido
Posts: 4
Joined: 13 Jun 2017, 02:56

09 Sep 2017, 00:59

Looks some problem with font icons:

Image
Image

Chrome version: Version 61.0.3163.79 (Official Build) (64-bit)
Last edited by giovannicandido on 10 Sep 2017, 16:29, edited 1 time in total.

giovannicandido
Posts: 4
Joined: 13 Jun 2017, 02:56

10 Sep 2017, 16:28

Solution was to change the URL in _fonts.scss

Code: Select all

@font-face {
  font-family: 'Material Icons';
  font-style: normal;
  font-weight: 400;
  src: url("../fonts/MaterialIcons-Regular.eot"); /* For IE6-8 */
  src: url("../fonts/MaterialIcons-Regular.woff2") format('woff2'),
       url("../fonts/MaterialIcons-Regular.woff") format('woff'),
       url("../fonts/MaterialIcons-Regular.ttf") format('truetype');
}

.material-icons {
  font-family: 'Material Icons';
  font-weight: normal;
  font-style: normal;
  font-size: 24px;
  line-height: 1;
  letter-spacing: normal;
  text-transform: none;
  display: inline-block;
  white-space: nowrap;
  word-wrap: normal;
  direction: ltr;
  -webkit-font-feature-settings: 'liga';
  -webkit-font-smoothing: antialiased;
}

I removed the local src

Code: Select all

local('Material Icons'),
local('MaterialIcons-Regular'),
I also download a new woff2 file from https://fonts.googleapis.com/icon?family=Material+Icons but I'm not sure if this is necessary, because it only works when I removed the local URL

Post Reply

Return to “PrimeFaces”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 24 guests