Error loading theme, cannot find "theme.css"

Post Reply
Posts: 1
Joined: 31 Jan 2018, 18:50

03 Feb 2018, 03:13

I followed and re-followed all instructions at but the following error still appears.

Error loading theme, cannot find "theme.css" resource of "primefaces-primefaces-poseidon-turquoise" library

Note: I had to add jar with maven, as a local repository.
Hope someone can help me soon.

Posts: 87
Joined: 10 Jan 2018, 16:04

09 Feb 2018, 11:40

You need to set up sass with this command line;

" sass -w src/main --sourcemap=none "

and you can install sass from here

Best Regards,

Posts: 4724
Joined: 29 Jun 2013, 12:38

18 Feb 2018, 21:18

Which way are you using theme.jar or theme*.sass files to apply theme to your project? If you want to use theme sass files, you need to provide css files from them using;
sass -w src/main/resources/ --sourcemap=none

Also, Tthese links can help to you; ... t.mp4?dl=0 ... t.mp4?dl=0 ... t.mp4?dl=0


Posts: 2
Joined: 22 Jan 2019, 18:23

22 Jan 2019, 18:40

i face the same error.
when i run the sass command: sass -w resources/ --sourcemap=none
i receive the error: could not find option or flag "-w"

Posts: 4724
Joined: 29 Jun 2013, 12:38

23 Jan 2019, 14:56

I think you use the new sass version. Please try the following command;

Code: Select all

sass --watch src/main/webapp/resources/:src/main/webapp/resources/ --no-source-map

Post Reply

Return to “Poseidon - PrimeFaces”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest