[RESOLVED] Menu does not work if webapp context is root

Post Reply
Posts: 34
Joined: 30 Dec 2013, 20:52

22 Oct 2021, 17:19

Primefaces: 10.0 - Verona theme 4.0 (but with primefaces 7+verona 3.0 seem work)

How to reproduce:

1) Compile the tag with:
sass --update src/main/webapp/resources:src/main/webapp/resources --no-source-map

2) Import in ecplice a "new maven project" from the compiled tag folder at the prevoius point

3) Run as on server, choose tomcat 8 (I have this server inside my ecplipse workspace).

All works fine on http://localhost:8080/verona/ 8-)

4) But I have to integrate the templete in a previous project with a context root "/", so I add to the pom.xml:


-refresh and clean the project and the server, maven update on the project..and run as on server and the application appears to:


At the firs look it seems ok, but when you try to use the menu it does not respond and clicking under the avatar the menu closes immediately.. :|

I'm not following the right method to deploy with "/" as context root instead of "verona" ?
Last edited by iljkr on 28 Oct 2021, 08:40, edited 1 time in total.
javax.faces-2.3 | primefaces-7 | tomcat 8.5

Posts: 34
Joined: 30 Dec 2013, 20:52

25 Oct 2021, 11:56

In the meantime I have carried out further tests.

It seems that deploying the application with a context root different from "/" the template works fine.
Example: http://localhost:8080/verona/ , http://localhost:8080/mycustomname/, www.yoursite.com/mycustomname/, https://www.primefaces.org/verona/ are all ok

Deploying the web app with "/" as context root there are problems to the functioning of the menu.
Example: http://localhost:8080, www.yoursite.com they have problems with the menu.

With "/" as context root, more details:
In particular, at the first deployment of the application it may seem that it works, but from the second restart of the application the menu stops working.
If you open an a new anonymous window of your browser, the menu returns to work, is there something in the browser* history that doesn't make it work? Is it a template bug?

*I tried with chrome, firefox and eclipse internal browser.
javax.faces-2.3 | primefaces-7 | tomcat 8.5

Posts: 34
Joined: 30 Dec 2013, 20:52

28 Oct 2021, 08:39

In the meantime the problem has been solved.
The launches of previous applications deployed on different context paths had left dirty cookies for localhost in my browsers.
After deleting all cookies for localhost (JSESSIONID and the one of the premium template) it also worked on context path root.
javax.faces-2.3 | primefaces-7 | tomcat 8.5

Posts: 4852
Joined: 29 Jun 2013, 12:38

22 Dec 2021, 09:02

Glad to hear, thanks a lot for the update!

Best Regards,

Post Reply

Return to “Verona - PrimeFaces”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest